Author Topic: So it's been a while....  (Read 16671 times)

Rich

  • Moderator
  • Member
  • Posts: 26
    • View Profile
So it's been a while....
« on: March 25, 2012, 09:44:37 PM »
A few of you may remember me on here. Most of you will have no clue, lol. I used to be (and apparently, still am) A Moderator on this site before I disappeared for a year or so. Well, I'm back!

This was my ride back then-


Here is what I am driving now (not a hood ride at all, hence my absence)

Started off looking like this-


And after a lot of this-


It now looks like this-















Well thats all for my re-Introduction for now. Now time for me to go lurk and check out every one's rides.

sean

  • Administrator
  • Member
  • Posts: 30
  • trying too hard
    • View Profile
Re: So it's been a while....
« Reply #1 on: March 30, 2012, 03:30:21 AM »
I go months without visiting here - laffo. 


Dat fuckin Benz looks great. I been thinkin about having one of the local shops drop a LS1 into one myself.

Rich

  • Moderator
  • Member
  • Posts: 26
    • View Profile
Re: So it's been a while....
« Reply #2 on: April 14, 2012, 07:31:30 PM »
there is a guy on one of the forums doing that, He calls it the LS-190E lol. But he's been at it for years. You have to make a custom cross member, fire wall, and trans tunnel. Should be awesome though.

arne

  • Member
  • Posts: 1
    • View Profile
Re: So it's been a while....
« Reply #3 on: November 25, 2017, 05:03:06 PM »
I go months without visiting here - laffo. 

Make that years for most people. ;)

(Yes, I know this looks like post 1, but I was on the old forum many, many moons ago.)